HSV Forum


Page 1 of 2 12 Last >>
Results 1 to 10 of 20
  1. #1
    Join Date
    Feb 2019
    Location
    NW Sydney
    Posts
    15

    Tune-Up for VS 5L Manual

    Hello All,

    As you may have read in my previous threads, I own an unmolested VS Clubsport 5.0L with a 5 speed manual that's travelled 172,000Km.

    My Clubby is in need of a tune-up, and the specialist mechanics that I've found such as OzTrack have told me that they can't assist, and others have suggested the fitting an after-market ECU or "chip" by people such as Haltech.

    All that's foreign to me, but I know that the car's not running well (e.g. engine revs. hunt up and down at idle) and that fuel consumption is excessive even with my sedate driving style.

    I want to keep everything original, and so need some help with locating an old-school mechanic in Northwest or Greater Western Sydney who knows the 5L V8 well enough to get it back into tune.

    Many thanks in advance.

  2. #2
    Join Date
    Jan 2017
    Location
    Sydney
    Posts
    54
    I wouldn't be going to LS shops for this. If a good mechanic can't sort out the issues and you need computer access/ want to retune, you need someone with something like Kalmaker software. If not you rip out the factory stuff and put in a Haltech etc. computer.

    Are injection perfection still in business? They did the original tune on my old 355ci Holden Stroker in my Senator using the factory computer before I was convinced by the late Jason Grey to have SAS redo it. What a mistake, tune was expensive but worse. I sold the car not long after.

    Sam's Performance also used to be very good with the Holden V8s but I think they just do LS stuff now.

  3. #3
    Join Date
    Jan 2004
    Location
    Perth, WA
    Posts
    7,826
    Don't listen to OzTrack, it doesn't need a tune, especially if you want to keep it standard. It sounds like it just needs a bit of TLC and possibly some sensors replaced.

  4. #4
    Join Date
    Nov 2016
    Posts
    747
    Maybe carbon buildup? You need a decent mechanic not a tune

  5. #5
    Join Date
    Jun 2010
    Location
    Adelaide
    Posts
    2,124
    Quote Originally Posted by Nth57l View Post
    Are injection perfection still in business? They did the original tune on my old 355ci Holden Stroker in my Senator using the factory computer before I was convinced by the late Jason Grey to have SAS redo it. What a mistake, tune was expensive but worse. I sold the car not long after
    Mark Heysmand at Injection Perfection is still going strong .... and possibly the only guy that will get your Delco Computer right ... because of his care and diligence ... he was also the one that Co-Developed the Kalmaker tuning software with Ken
    GR

    Bite off more than you can chew .... then chew like hell to you've eaten it!

  6. #6
    Join Date
    Dec 2016
    Posts
    146
    A car can't one day be driving fine with the same components then next day drive shit and the cause of it is "needing a tune".

    Culprit will be something quite easy.

    My suggestions are 1) Vac leak.

    There are loads of vac hoses on this model, you will find some at the back of the engine some at the front. Check them all for going brittle. Use online diagram of all hoses to find them all.

    2) Air idle controller.

    This will cause hunting and strange rev issues.

    3) Oxygen sensor.

    This will normally only present itself after the car is warm, symptoms are running fine cold then using shitloads of fuel and running badly when warm.

    These 3 can be done by yourself for next to nothing and the best place to start.

    Lastly once all that is in order, new plugs, leads, rotor cap, rotor button will transform these old cars.

    You don't need anything fancy or after market, just same for same at repco.

    Does not hurt to change fuel filter also while you are at it.

    For my money any car of this age should have it coolant temp sensor replace also as insurance.
    Last edited by OldMateGTS; 4 Weeks Ago at 11:40 PM.

  7. #7
    Join Date
    Apr 2009
    Location
    Keiraville, NSW
    Posts
    1,043
    Know two good shops and one good auto-electrician in Wollongong if local help can't be found. 400,000 plus on the WK and still going strong.

  8. #8
    Join Date
    Feb 2019
    Location
    NW Sydney
    Posts
    15

    Many thanks everyone.

    Many thanks to all - I'll let you know the outcome.

  9. #9
    Join Date
    Dec 2011
    Posts
    54
    I had similar problems years ago on my VP 5 litre
    Being a mechanic I gave it a major service replaced all the usual sensors removed the inlet manifold replaced the gaskets and had the injectors cleaned.

    The hint was still there. So at idle it would vary about 150rpm at times. Luckily I had a friend with an identical VP swapped memcal between he cars and the problem followed the memcal.

    I canít remember is the VS uses a memcal but if you have access to another vehicle might be worth a shot.

    I canít explain how a memcal would cause that but it did. Interesting enough a 5.0 came into work not long after and much to the doubt of the other techs I replaced the memcal to fix it.

    However id be starting with a major new sensors etc.


    Sent from my iPhone using Tapatalk

  10. #10
    Join Date
    Feb 2019
    Location
    NW Sydney
    Posts
    15
    UPDATE.......I've now taken the Clubby to a tuning specialist who, after checking ECU codes, undertook the following in order to correct the fluctuating revs that hunt between 500 and 1500 rpm at idle:

    1) The air idle controller / stepper motor was cleaned and accelerator cable adjusted.........the cable was reportedly too tight (?).
    2) O2 Sensor replaced
    3) Smoke testing to identify vacuum leaks...none found.
    4) Throttle body cleaned.

    No improvement, so now they're suggesting that as the fuel flow is only 500mL/ min even after I've recently replaced the filter, that the car needs a new fuel pump in the first instance, and perhaps an off-car injector service.

    Problem is that once warm, even with the reported low fuel flow the car drives beautifully on the tollway at 100kM/h (?).

    So with all of the above considered and after spending $800 on items 1 - 4 above, I'm reluctant to spend even more on the fuel pump and injectors if those are not the problem.

    I'm really clutching at straws now, but could an indicated engine temp that never exceeds 25% of full scale be telling the ECU to increase the idle speed......that is confusing the ECU?

    I don't want to spend more money for no improvement, but the mechanic recons that regularly driving the car with insufficient fuel flow could blow the engine!!

    All assistance and opinions greatly appreciated.
    Last edited by Lizzo1975-; 2 Weeks Ago at 03:31 PM.







Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •