HSV Forum


Page 2 of 2 First << 12
Results 11 to 19 of 19
  1. #11
    Join Date
    Nov 2016
    Location
    Springfield QLD
    Posts
    117
    Sometimes I get similar when I try to start the car in a hurry. Starts then dies and I get a code sometimes for fuel pump immobiliser. If I take my time and press in the key, wait for the immobiliser beep before I crank it never happens. So that could be the right direction to look.

    Sent from my HTC 2PS6200 using Tapatalk

  2. #12
    Join Date
    Nov 2013
    Posts
    597
    Best advise I can give you is take it to a reputable mechanic who specializes in diagnostics.

    To me it sounds like the Body Control Module has gone to lunch.

    Common symptom is engine cranks & starts & runs for a second & then cuts out.
    And it usually fails with no warning.

    Worst case scenario is the Body Control Module (BCM) & Power Interface Module (PIM)
    have gone out together.

    Either way you will need the fault correctly diag, & if it is a BCM or PIM the vehicle will
    need the new modules to be programmed to your car, together with new keys.

    Good luck.
    GTSR HERON WHITE MANUAL build # 0068
    VK HDT Calais Director Build # 2107
    2010 VE SSV SPECIAL EDITION

  3. #13
    Join Date
    May 2017
    Posts
    24
    Thanks TPKW30. I rang my mechanic today and that's exactly what he said. He was saying he had a VZ monaro do the same thing last month. Apparently the PIM units are no longer available new so if it's dodgey we have to get one from the wreckers. Not too keen on second hand parts but what do you do. Getting the car towed out to him when I can and we will go from there.
    Thanks again for an obviously insightful post.

  4. #14
    Join Date
    Nov 2013
    Posts
    597
    Quote Originally Posted by Blackbeast View Post
    Thanks TPKW30. I rang my mechanic today and that's exactly what he said. He was saying he had a VZ monaro do the same thing last month. Apparently the PIM units are no longer available new so if it's dodgey we have to get one from the wreckers. Not too keen on second hand parts but what do you do. Getting the car towed out to him when I can and we will go from there.
    Thanks again for an obviously insightful post.
    Not sure where you are located, but a company called "injectronics" sells recond exchange
    units or they can repair yours.

    Here: - http://www.injectronics.com.au/

    Your mechanic will have to send the BCM, ECU & keys to them for testing.
    Send the PIM for good measure as well.

    Injectronics will need the "SECURITY" number for your car as well.
    (Not radio code, but similar, found on security card that came with vehicle)

    Once back your mechanic will have to program the new bits to your car.
    GTSR HERON WHITE MANUAL build # 0068
    VK HDT Calais Director Build # 2107
    2010 VE SSV SPECIAL EDITION

  5. #15
    Join Date
    May 2017
    Posts
    24
    To finish this post and hopefully help someone else if they have similar dramas this was the outcome.
    Got all of the sucurity and comms checked PIM, BCM ECUearths etc no issues. Rob from House of Power helped me out heaps. We removed the fuel line from the injector rail and although there was fuel we had no pressure. Removed the fuel tank and fuel pump assembly to find the delivery hose from the pump to the delivery head had come off. It was just in connection with the hose tail which is why it would fire but when the pressure came on the fuel would just leak past the fitting and run back into the tank. As I broke 1 of the hose fittings on the delivery head of the fuel pump we replaced the whole unit and SUCCESS. Now have a spare fuel pump if I have a failure down the track.
    Thanks to everyone for the help.

  6. #16
    Join Date
    Apr 2016
    Location
    Liverpool Sydney
    Posts
    480
    Quote Originally Posted by Blackbeast View Post
    To finish this post and hopefully help someone else if they have similar dramas this was the outcome.
    Got all of the sucurity and comms checked PIM, BCM ECUearths etc no issues. Rob from House of Power helped me out heaps. We removed the fuel line from the injector rail and although there was fuel we had no pressure. Removed the fuel tank and fuel pump assembly to find the delivery hose from the pump to the delivery head had come off. It was just in connection with the hose tail which is why it would fire but when the pressure came on the fuel would just leak past the fitting and run back into the tank. As I broke 1 of the hose fittings on the delivery head of the fuel pump we replaced the whole unit and SUCCESS. Now have a spare fuel pump if I have a failure down the track.
    Thanks to everyone for the help.
    Good outcome, annoying - but good outcome. Enjoy the car

    LS2 V3 Vortech Supercharged
    607rwhp

  7. #17
    Join Date
    Sep 2010
    Location
    Bondi
    Posts
    1,038
    Quote Originally Posted by Blackbeast View Post
    To finish this post and hopefully help someone else if they have similar dramas this was the outcome.
    Got all of the sucurity and comms checked PIM, BCM ECUearths etc no issues. Rob from House of Power helped me out heaps. We removed the fuel line from the injector rail and although there was fuel we had no pressure. Removed the fuel tank and fuel pump assembly to find the delivery hose from the pump to the delivery head had come off. It was just in connection with the hose tail which is why it would fire but when the pressure came on the fuel would just leak past the fitting and run back into the tank. As I broke 1 of the hose fittings on the delivery head of the fuel pump we replaced the whole unit and SUCCESS. Now have a spare fuel pump if I have a failure down the track.
    Thanks to everyone for the help.
    Glad to hear you found the cause and fixed.
    will have to keep this one in the memory bank in case it happens to mine.
    Just 1 question , had you played with the fuel pump at any stage before the problem arose or did the hose just come off by itself?

  8. #18
    Join Date
    May 2017
    Posts
    24
    Fuel pump was replaced with a Walpro unit when the engine was stroked. Builder used the wrong hose and clamps. Pretty poor to be honest. God only knows how long the 17k engine rebuild will last!

  9. #19
    Join Date
    Nov 2016
    Posts
    206
    I had an engine rebuilt and a fuel line popped off the fuel rail as it wasnt pushed over the raised portion
    Pissed fuel all over my hot extractors
    Lucky it didnt catch fire

    Then a few months later a valve spring broke and trashed the piston







Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •