HSV Forum


Page 2 of 2 First << 12
Results 11 to 14 of 14
  1. #11
    Join Date
    Feb 2016
    Posts
    7
    Cheers guys. Got her tinted, looks mint.

    Attached Images
    Last edited by Bennoz; 01-05-2016 at 05:16 PM.

  2. #12
    Join Date
    Feb 2016
    Posts
    7
    Quote Originally Posted by Strick View Post
    Hah, thatll do it! Are the factory gearboxes weak in those?

    Hows the FWD go with the extra power, does it get it to the ground ok?
    Not...really. The cluster used in them is all but the same as an Evo. It's the primary input bearing that can't handle the torque. It's a pretty ordinary ball bearing, whereas the evos use tapers. Tried to convert it, but there's just not enough meat in the housing.

    Getting it down.. well that's challenging lol. Feather the throttle or torque steer towards the nearest tree or power pole lol.

    Attached Images
    Last edited by Bennoz; 01-05-2016 at 05:21 PM.

  3. #13
    Join Date
    Feb 2016
    Posts
    7
    Finally got around to pulling the blower to do pulleys & spacers






  4. #14
    Join Date
    Feb 2014
    Posts
    5,152
    Your brown/beige solid isolator on the left is a genuine eaton solid isolator I would re-install it not whatever that black one is.

    If the material of that black one is crappy regenerated plastic from china the potential for it expanding and growing inside and binding up on charger is very high, then if the plastic is able to withstand not only heat but shock loads.

    A lot of these copy cat companies simply copy without any knowledge of what they are making and why and what it needs to withstand.

    I see you have blower spacer plates there too, if they don't have o-rings they are also a Chinese knock off design.
    You can see a few failures here of the chinese stuff: http://www.hsvforum.com.au/showthrea...-spacer-plates

    2014 HSV VF GTS
    2017 HSV GTSR
    http://www.facebook.com/ForcedInductionInterchillers
    Australia's Fastest 6.2L 1900 LSA VF GTS with a Stock Bottom End
    9.700 @143.14mph 17/July/2017
    V-Box Results 0-100km/h in 2.47sec







Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •