PDA

View Full Version : e3 head unit troubles. can anyone help



fireblade73
03-08-2012, 08:15 PM
hi guys and girls iv got a e3 clubby and every now and then while im driving the head unit cuts out and restarts with the hsv logo . it happens 2 to 3 times per trip . has this happend whith any other e3 owners. and when playing in usb mode it some times sounds like it jumps a second while listening to music . thanx for any help

dannym81
03-08-2012, 08:43 PM
Yep. I've had the same issues in my e3 Maloo. Sometimes I've had to turn the ignition off in traffic to restart the screen. Sometimes I've had sound and no screen. Happy to hear feedback on this also.

220isenator
03-08-2012, 08:55 PM
There have been issues with the EDI systems mentioned before. I believe dealers solved these issues for customers under warranty.

Ijustgotone
03-08-2012, 09:19 PM
Yeah I have an e3 clubby that does similar things from time to time, but it's mostly at engine start and isn't often enough to worry about taking to a dealer.

fireblade73
03-08-2012, 09:25 PM
thanx guys ill give the dealer a call in the morning and book it in. hopfully its just a software update

zclubby
03-08-2012, 11:32 PM
I have an MY12 and never had an issue. Assuming you guys have an 11, therefore it should be fixed with a software upgrade

adr8
04-08-2012, 12:06 AM
Never had a problem, mine is Oct 2010 build. There was a software upgrade for vehicles built between Sept 2010 to 8 April 2011, received a letter from Holden for this and subsequently had it installed. I have been told there are more recent updates but these will only be installed if you are having problems with your IQ/EDI. Should be covered under warranty.